The secundary menu is not working

SupportCategory: TA PlutonThe secundary menu is not working
Netwave asked 3 years ago

I am using the theme as it is in your demo, but I can not use the secundary menu in pages / posts, how can I change the menu?
On the home page is correct, but the Blog pages and the pages created does not change the menu, why?
Thank U

12 Answers
Rohit Staff answered 3 years ago

Hello, please refer to theme documentation to set up your menus. Thanks!

Netwave answered 3 years ago

I have consulted the theme of documents but can not find enough information to solve the problem. I have configured two menu areas, one for the home page with the Primary area and another for pages / posts with Secundary area, but this does not appear.

Rohit Staff answered 3 years ago

Hello, would you please provide a screenshot for your menu settings? Thanks!

Netwave answered 3 years ago

Can I send email?

Rohit Staff answered 3 years ago

Yes, you can sent it to hi@themeart.co. Thanks!

Anonymous answered 3 years ago

Hello
I have the same issue with my homepage and my blogpage
The conditions for primary menu is set for front-page else secondary in header.php
But a blog page is consider as a front-page isn’it ? like a st

Rohit Staff answered 3 years ago

Hello, the primary menu is only for front-page, and the secondary menu is for non-front-page. The blog page is not the front-page. Thanks!

Anonymous answered 3 years ago

@Kevin : thanks for your quick reply ūüôā
Unfortunately can’t find how to solve my issue with the secondary menu that not change on my blogpage¬†
PS : your Pluton¬†theme is well build, very easy to configure, clean and beautifull… thks for the job
Regards 
Phil

Rohit Staff answered 3 years ago

Hello, would your please provide me two¬†screenshots? One for “Settings” -> “Reading”, another for “Appearance” -> “Menus”. Thanks!

Anonymous answered 3 years ago

@Kevin : just sent you a mail on your hi@themeart.co mail box
Thanks
Phil

Rohit Staff answered 3 years ago

Your settings are correct but you have wrong links. For primary menu, you can use relative path such as “#client” for the link. But for secondary menu, you should use absolute path such as “/#client”.

Anonymous answered 3 years ago

I would like to thanks Kevin for his efforts to solve my menu issue ūüôā
To activate the 2 menus they have to be named “Primary” for the primary menu and “Secondary” (in appearence/menu) for the second one !¬†
Kevin gave me a real good support… may be better than some of Premium Themes
Thanks again