Shortcodes not working

SupportCategory: TA PortfolioShortcodes not working
517design asked 3 years ago

Hi,
I’m using ta-platon (great theme!) I’ve downloaded some shortcode plug-ins (Column Shortcodes, Shortcodes Ultimate and TinyMCE Advanced) They show up in the bar with all the buttons in my Visual and Text editor when I create a page or blog in the regular section of wordpress. However they don’t show in the Ta-pluton section of my dashboard; Service Settings, About Us Settings, Portfolio Settings etc…. Actually the Shortcodes Ultimate button shows and enters the shortcode into my editor but the code does not work. All I get is the actual shortcode on my page. EXAMPLE.. I see this on my page [su_pullquote]My Quote[/su_pullquote] instead of the big quotation marks around the words My Qoute. I would really like the above shortcodes to work in my Ta-Pluton theme. OR…. If you have another shortcodes plugin that will work with the them. Any ideas would be great!
Thank you for your time. Greg

3 Answers
Rohit Staff answered 3 years ago

Hi Greg, I’m afraid I can’t give you some help. TA Pluton theme uses Redux Framework as Theme Panel, which is not developed by me. It seems that there is compatibility problem with them. I suggest you get help from plugin developers. Thanks!

517design answered 3 years ago

Thats ok and thanks for the quick response. I found a work around.
I installed the “insert page” plugin by Paul Ryan.
Then I added this code to my template-home.php file in the place I wanted my new formatted content to be located.
?php
if (is_home() || is_front_page()) {
echo do_shortcode(“[‘your page short code here’]”); // replace [‘your page short code here’] with your shortcode
}
?>
Then I created a new page and entered my content using my installed shortcode plugins (because they work on the pages and posts)
Then I went to Posts > Add New. You’ll have a button for interring a shortcode from a page. Click the button, select the page you just created, go to Options and choose Content.
This will add the shortcode to your new post. No need to save the post just copy the code and paste it into the php code above on your template-home.php file. 
Thats it! Worked great! Now my client can go in and easily edit the content.

Rohit Staff answered 3 years ago

Hi Greg, thanks for your solution. You rock!