How to disable css scroll animation

SupportCategory: Ta MeghnaHow to disable css scroll animation
Alan Vazquez Staff asked 2 years ago

Hi,
 
I would like to know how I can disable the animation when scrolling down, since it looks “laggy”. The page size is 423kb, so the site should not be slow. However, that animation makes it feel kinda slowly.
 
Thank you very much!

7 Answers
Rohit Staff answered 2 years ago

Hello, please open the file ‘/js/app.js’, go to line 254, delete the following codes.

wow = new WOW({
 animateClass: 'animated',
 offset: 120
});
wow.init();

Then open the file ‘functions.php’, delete line 39.

wp_enqueue_style( 'ta-meghna-animate-style', get_template_directory_uri() . '/layouts/animate.min.css', array(), '', 'all' );

And delete line 185.

wp_enqueue_script( 'ta-meghna-wow', get_template_directory_uri() . '/js/wow.min.js', array(), '1.0.3', true );
Alan Vazquez Staff answered 2 years ago

Hi, Kevin,
 
I did exactly what you said, but now the slider is not showing, and when scrolling down, the page keeps having that animation. the site is mexifish.com . The code I deleted, does it affect the slider? If so, then I’m sorry, perhaps I didn’t explain myself well.
 
Thank you very much.

Rohit Staff answered 2 years ago

Hello, please disable CloudFlare first to debug the problem. Thanks!

Alan Vazquez Staff answered 2 years ago

Ok. CloudFlare is disabled now. What should I do next?
 

Rohit Staff answered 2 years ago

Hello, just checked your page, slider works well and animation has been disabled. Please use Ctrl+F5 to refresh your browser and check again.

Alan Vazquez Staff answered 2 years ago

Curious. It was working fine with CloudFlare before deleted those lines. So, should I keep CloudFlare disabled?
 

Rohit Staff answered 2 years ago

Hello, you can try to clean the CloudFlare cache first and try again. If it still not work, you need disable CloudFlare Rocket Loader.