Having trouble with one page scrolling

SupportCategory: TA PlutonHaving trouble with one page scrolling
Tony asked 2 years ago

Hello there, 
   Starting using wonderful Pluton theme. I have a little trouble however to get the ‘one page scroll’ feature to work for some reason. I have declared the Section ID’s, (some of them are 2 words and i have set them as blog-example, or blog_example but nothing happens), but when I visit the page and click on a menu item, it redirects me to a general page, not further down the main page. 
I don’t have that many plugins installed, and I even tried de activating them, but still nothing. I am on a local install so far, so not able to provide any links. Can you give me some suggestions for this? 
Thanking you in advance..!
 

8 Answers
Rohit Staff answered 2 years ago

Hello, your site URL please. Thanks!

Tony answered 2 years ago

I am on a local install so far, so not able to provide any links.

 

Rohit Staff answered 2 years ago

Hello, I’m afraid it’s difficult for me to give you some suggestions, as I need to check your source code to find out the problem. Hope your understanding.

Tony answered 2 years ago

Hi, 
 No I don’t really understand! Surely there must be suggestions as to why the one page scroll does not work, that you can help with? Maybe I can send you screenshots of dashboard items or something? Can’t be the first time you have had this issue…I really like this theme which is why I contributed, and would be a real shame if I had to drop it and move to something else!
 
Thank you..

Rohit Staff answered 2 years ago

Hello, please send me a screenshot for your menu settings. Thanks!

Tony answered 2 years ago

Kevin, 
 Just realised…how exactly am I supposed to send you these screenshots? There is no option in here that I can upload is there? Sure you already know that..?!
Do you have an e mail I can send them too? I can’t waist my time anymore with this please. I need to know if you can actually help me..!!!!!!!!!!!!!!!!!!!!

Tony answered 2 years ago

Hey thanks for this..will be sending them to you!
 

Tony answered 2 years ago

For anyone wondering how this was solved: When creating the Primary navigation menu, you need to keep in mind the following: <ol> <li>Create <span style=”text-decoration: underline”><em>Custom links</em></span> instead of regular Menu Pages that you insert. These Custom links should be as many as the pages you want to include in your Primary menu.</li> <li>When creating custom Menu links you need to put ” #example” or “#example-page” in the URL field, and this name should be exactly the same name you have given your ID’s, inside the theme’s Customizer.</li> </ol> Hope this helps…!